Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем.(a=0 признак окончания ввода , ноль не входит в последовательность). программа должна вывести количество и сумму всех чисел последовательности.

theta4ka theta4ka    3   30.07.2019 12:10    5

Ответы
пухля13 пухля13  03.10.2020 17:24
Var a, b, c: integer;
begin
b:=0;
c:=0;
readln(a);
while a <> 0 do
begin
b:=b+1;
c:=c+a;
readln(a);
end;
writeln('Кол-во: ',b);
writeln('Сумма: ',c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика