Программа получает на вход целые числа, количество введённых
чисел неизвестно, последовательность чисел заканчивается числом
0 (0 – признак окончания ввода, не является членом
последовательности). Количество чисел не превышает 1000.
Введённые числа не превышают 30 000. Гарантируется, что в
последовательности есть хотя бы одно число, кратное трём.
Программа должна вывести наименьшее число, кратное трём.

EgoSik1 EgoSik1    1   05.02.2022 22:10    8

Ответы
Ivankozyr69gmail Ivankozyr69gmail  05.02.2022 22:20

#include<iostream>

using namespace std;

int main(){

   int temp,min,flag;

   while(cin>>temp){

       if (!(flag) && temp%3==0){

           min=temp;

           flag++;

      }

      if(temp%3==0 && temp<min){

           min=temp;

       }

   }

   cout<<min;

}

как-то так.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика