tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программа паскаль.дан
Программа паскаль.дан массив целых чисел. сдвинуть его циклически на один элемент вправо.
Oks111111
1 11.07.2019 18:50
6
Ответы
covik332
17.09.2020 23:15
Const n = 10;
Var m : array[1..n] of Integer;
i,k : Integer;
Begin
For i:=1 to n do
Begin
m[i]:=i;
Write(m[i],' ');
end;
Writeln;
k:=m[n];
For i:=n downto 2 do m[i]:=m[i-1];
m[1]:=k;
For i:=1 to n do Write(m[i],' ');
Writeln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
MaksimVip12
24.10.2020 17:12
Напишите программу буквы(алгоритм) «н» , «Р» с рисунком....
danaj04
24.10.2020 17:14
Составить программу вычисления и печати в виде таблицы значений функции и соответствующих аргументов, отладить программу на компьютере и получить распечатку программы и...
1234567891155
27.05.2019 06:20
Статья, набранная на компьютре,содержит 8 страниц,на каждой странице 40 строк,в каждой строке 64 символа.определите информационный объем статьи в кодировке unicode,в которой...
kuzyaevkuzyaev2
27.05.2019 06:10
Считая,что каждый символ кодируется двумя байтами,оцените информационный объем следующего предложения в кодировке unicode : один пуд - около 16,4 килограмм...
lera192837465
07.07.2019 17:00
Расставить в комнате 5 стульев так чтобы по над каждой стеной было по 2 стула...
ElizavetaMusic
07.07.2019 17:00
Заполните пропуски числами: =__байт= 8192 бит гбайт =1536 мбайт=__кбайт...
Education26
26.09.2019 00:20
Базы данных – это: 1) совокупность данных, организованных по определенным правилам; 2) совокупность программ для хранения и обработки больших объемов информации; 3) интерфейс,...
kazekb
17.04.2019 07:00
Установите соответствие между событиями и датами. К каждой позиции первого столбца соответствующую ей позицию...
k666goblin
17.04.2019 07:00
Прочитайте отрывок из воспоминаний известного хирурга Н.И. Пирогова и напишите название войны, о которой идет речь. «Я никогда...
KamAbi003
17.04.2019 07:00
Что из названного относилось к причинам поражения России в Крымской войне? Выберите два верных положения. Запишите...
Популярные вопросы
Какая композиция чайковского звучит в балете щелкунчик...
1
10 Выберите правильный ответ. Назовите людей, которым удалось создать...
2
1. Особливостями будови опорно-рухової системи амфібій порівняно з рибамиВиберіть...
1
Read and put a tick (M) or a cross (X).1 Uranus was discoveredin 17812...
3
НУЖНО 1) Что такое подземные воды? 2) Откуда поступает вода, образующая...
3
Крайня південна точка материка Євразія...
2
Какое распределение электронов по электронным слоям соответствует атомам...
2
Какие команды присваивания составлены правильно? 4+Y=:B B=Y+2 B=Y B:=Y...
2
1.Какое из следующих последовательностей символов можно считать операторами...
2
Сколько известно количество видов одноклеточных организмов?...
3
Var m : array[1..n] of Integer;
i,k : Integer;
Begin
For i:=1 to n do
Begin
m[i]:=i;
Write(m[i],' ');
end;
Writeln;
k:=m[n];
For i:=n downto 2 do m[i]:=m[i-1];
m[1]:=k;
For i:=1 to n do Write(m[i],' ');
Writeln;
end.