Программа не сложная , но я совсем не умею программировать ! написать программу, которая выводит все слова, содержащие букву 'a'.

kutinaI kutinaI    2   27.06.2019 07:50    1

Ответы
rom252 rom252  02.10.2020 12:55
Я б не сказал что програма не сложная

var s:string;
i,k1,k2,w:byte;
word,a:boolean;
begin
readln(s);
k1:=1;
word:=true;
a:=false;
s[length(s)+1]:=' ';
for i:=1 to length(s)+1 do
begin
if i=length(s) then begin k2:=length(s); word:=false; end
else if (s[i]=' ') and (word=true) then begin k2:=i; word:=false; end
else if s[i]=' ' then begin k1:=i; word:=true; end; 
if s[i]='a' then a:=true; 
if (a=true) and (word=false) then 
begin a:=false;
for w:=k1 to k2 do
write(s[w]);
write(' ');
end;
end;
writeln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика