Программа на с++: объединение прямоугольников. даны n прямоугольников (n ≤ 10), стороны которых параллельны осям координат, а координаты вершин являются действительными числами. напишите программу, которая вычисляет площадь фигуры, получаемой в результате объединения n прямоугольников. решите .

suminjenya suminjenya    3   01.10.2019 19:50    13

Ответы
kirstav64 kirstav64  10.09.2020 22:16

Я так понимаю из задания вы это хотели.

В следующий раз самостоятельно хоть попытайтесь сделать,и приложите ваше решение к вопросу.

#include<iostream>;

using namespace std;

int main()

{

 

int n;

float  height, width,square=0;

cout << "pls enter count rectangle" << endl;

while (true) //Бесконе4ный цикл

{

 cin >> n;

 if (n <= 10 && n > 0)//как нашли-выходим из цикла

  break;

}

 

cout << "pls enter height" << endl;

cin >> height;

cout << "pls enter width" << endl;

cin >> width;

cout << endl;

for (int i = 0; i < n; i++)

{

 square = square + (height * width);

}

cout <<"your answer : "<< square << endl;

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика