tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программа на паскале заполнить
Программа на паскале заполнить линейный массив по формуле c[i]=16*x-i/9-7
xtreil181пингвинчик
3 15.09.2019 13:50
5
Ответы
tjumentseva20031
07.10.2020 17:32
//PascalABC.NET
//Версия 3.3, сборка 1611 (06.01.2018)
begin
var x:=ReadInteger('x=');
var c:=ArrGen(ReadInteger('Введите размер массива->'), i->16*x-(i+1)/9-7); c.Println;
end.
Пример:
x= 3
Введите размер массива-> 5
40.8888888888889 40.7777777777778 40.6666666666667 40.5555555555556 40.4444444444444
ПОКАЗАТЬ ОТВЕТЫ
saidovabduraxm
07.10.2020 17:32
PROGRAM A23;
const
max = 42;
var
с:array[1..max]of real;
x:integer;
i:byte;
BEGIN
writeln('Заполнить линейный массив по формуле c[i]=16*x-i/9-7');
write('Введите x='); readln(x);
writeln(' ');
writeln('Массив' );
for i:=1 to max do begin
с[i]:=16*x - i/9 -7;
write(с[i], ' ');
end;
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Stepanych2017
15.04.2019 19:29
Найти значение выражения y=5x2-8x+20, при x - любое вещественное число...
artem20051105
15.04.2019 19:27
Молю! написать полные программы. язык: pascal...
isshaixyt5
10.03.2019 12:39
Pascalabc.net, обязательно через массивы, . напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся...
stars28082003
10.03.2019 12:38
Pascalabc.net, обязательно через массивы, . напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. программа...
khgfdl
10.03.2019 12:33
Вбюро по туризму составляются маршруты путешествий для автотуристов, которые должны проехать из пункта s в пункт r и по пути осмотреть все местные достопримечательности....
Janna91
10.03.2019 12:31
Вывести на экран такие трехзначные числа, у которых квадрат 1 цифры равен двузначному числу, составленному из 2 и 3 цифры (используя оператор repeat)...
cjjlkfjiii
10.06.2019 20:20
Заданы два натуральных числа. определить, является ли среднее арифметическое этих чисел целым числом. решить в паскале....
Bon2000
10.06.2019 20:20
Примеры известных вам носителей информации...
Лераuse
12.05.2019 11:12
Написать программу на паскале ( 20 )...
nzinulla
12.05.2019 11:05
Впрограмме «: =» обозначает оператор присваивания, знаки «+», «–», «*» и «/» – соответственно операции сложения, вычитания, умножения и деления. правила...
Популярные вопросы
Решите уравнение1) 3,6х - 1,6х + 10,4 = 24,4 + 0,6х2) /2х+8/ =10...
2
Задайте функцию y=x+3 описанием...
1
Удваивается согласная и добавляется ed слова исключение ! что за...
3
Help Изобразите на координатной прямой и запишитепересечение и...
1
Узнайте, какие организации занимаются вопросами социальной защиты...
1
те естествознание 6 класс ...
1
Как появляются электромагнитные волны? 1. только из-за вектора...
2
АЙТЫЛЫМ 9 -тапсырма.Диалог. «Тарихшымен сұхбат». Рөлдік ойын. Мәтіннің...
1
В первом ряду кустов смородины в 3.5 раза больше, чем во втором....
2
Қазақ халқының салт-дәстүрлері бұрынғы тұрмыс-тіршілікпен байланыс-...
1
//Версия 3.3, сборка 1611 (06.01.2018)
begin
var x:=ReadInteger('x=');
var c:=ArrGen(ReadInteger('Введите размер массива->'), i->16*x-(i+1)/9-7); c.Println;
end.
Пример:
x= 3
Введите размер массива-> 5
40.8888888888889 40.7777777777778 40.6666666666667 40.5555555555556 40.4444444444444
const
max = 42;
var
с:array[1..max]of real;
x:integer;
i:byte;
BEGIN
writeln('Заполнить линейный массив по формуле c[i]=16*x-i/9-7');
write('Введите x='); readln(x);
writeln(' ');
writeln('Массив' );
for i:=1 to max do begin
с[i]:=16*x - i/9 -7;
write(с[i], ' ');
end;
END.