Программа на c++ напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105

krazy4550 krazy4550    3   07.09.2019 13:20    20

Ответы
wolk2289 wolk2289  09.09.2020 21:27
#include <iostream>
using namespace std;  

int multiply(int x, int y)
{
    if(y == 0)
      return 0;
      if(y > 0)
      return (x + multiply(x, y - 1));
       if(y < 0)
      return -multiply(x, -y);
}
   
int main()
{
   int a, b;
   cin >> a >> b;
   cout << multiply(a, b) << endl;
   return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
feliz3600 feliz3600  09.09.2020 21:27
#include <cstdio>
#include <cstdlib>

int
main(void)
{
    int a = 0;
    int b = 0;
    scanf("%d %d", &a, &b);
    long long mul = 0;
    for (int i = 0; i < abs(a); i++) {
        mul += b;
    }
    if (a < 0) {
        mul = -mul;
    }
    printf("%lld\n", mul);
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика