Программа для C, не для C++
Задача №112149. Расстояние
Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.

Входные данные
В первой строке вводятся через пробел координаты первой точки (сначала x -координата, потом y -координата), во второй строке в том же порядке – координаты второй точки. Все координаты – вещественные числа.

Выходные данные
Программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части.

Xmitejr Xmitejr    1   29.10.2020 21:07    47

Ответы
vitaliy555555 vitaliy555555  28.11.2020 21:07

#include <stdio.h>

#include <math.h>

int main()

{

double x1, x2;

double y1, y2;

printf("Введіть координати точок:\n");

scanf("%lf%lf%lf%lf, &x1, &x2, &y1, &y2);

double result = sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));

printf("%.3lf\n", result)

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика