PROGRAM Z1; Образец
VAR A, H: INTEGER;
S: REAL;
BEGIN
WRITELN (‘ВВЕДИ ОСНОВАНИЕ ТРЕУГОЛЬНИКА’);
READLN (A);
WRITELN (‘ВВЕДИ ВЫСОТУ ТРЕУГОЛЬНИКА’);
READLN (H);
S:=A*H/2;
WRITE (‘ПЛОЩАДЬ ТРЕУГОЛЬНИКА РАВНА ‘, S);
END.
Составьте программы, которые позволят решать задачи:
1) Вычислить периметр треугольника
Переменные:
А, В, С – стороны треугольника (целые числа)
P – периметр (целое число)
Входные данные Выходные данные
3
4
5
12
2) Вычислить периметр и площадь квадрата
Переменные:
А - сторона квадрата (целые числа)
P – периметр квадрата (целое число)
S – площадь квадрата (целое число)
Входные данные Выходные данные
3 12
9
3) Вычислить площадь трапеции
Переменные:
А, В – основания трапеции (целые числа)
H – высота трапеции (целое число)
S – площадь трапеции (вещественное число)
Входные данные Выходные данные
10
7
4
34