При регулярных выражений: 1. написать программу, которая проверяет, является ли введенная с клавиатуры строка двоичным числом. 2. написать программу, которая проверяет, является ли введенная с клавиатуры строка дробным числом. 3. дана строка. написать программу, которая находит в строке и выводит на экран только двузначные числа.

мпппеекк1 мпппеекк1    1   31.08.2019 06:10    8

Ответы
freedomman87 freedomman87  06.10.2020 06:28
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  if s<>s.MatchValue('[01]+') then Write('не ');
  Writeln('двоичное число')
end.

Пример
010101111011
двоичное число

begin
  var s:=ReadlnString;
  if s<>s.MatchValue('[\+-]?\d+.\d+') then Write('не ');
  Writeln('дробное число')
end.

Пример
12.54
дробное число

begin
  var s:=ReadlnString;
  s.Matches('\s([\+-]?\d{2})\s').Select(t->Trim(t.Value)).Println;
end.

Пример
123.3 15 -11.7 +21 23.2 51 9 182
15 +21 51
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика