Превратить все значения массива С(9) стоящие после наименьшего значения массива в ноль. Напишите программу на С++. Я написала программу прикреплённую ниже, но после введения значений массива ничего не происходит и не выходит


Превратить все значения массива С(9) стоящие после наименьшего значения массива в ноль. Напишите про

sashaboyko999p089tm sashaboyko999p089tm    2   26.03.2021 18:57    3

Ответы
potapovp016 potapovp016  25.04.2021 18:58

#include <iostream>

using namespace std;

signed main() {

setlocale(LC_ALL, "Rus");

int C[9], min, i_min = 0;

for (int i = 0;i<9;i++){

 cin >> C[i];

}

min = C[0];

for (int i = 1; i < 9; i++) {

 if (C[i] < min) {

  min = C[i];

  i_min = i;

 }

}

for (int i = i_min+1; i < 9; i++)//если надо и минимум обнулять, то нужно убрать +1

 C[i] = 0;

 

cout << endl;

cout << "Изменённый массив: ";

for (int i = 0; i < 9; i++)

 cout << C[i] << " ";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика