После прочтения теоритической части по теме "Программирование циклов с заданным условием продолжения работы" рассмотрите блок-схемы 1 и 2.

На блок-схему 1 написана программа на языке Паскаль.

program a_1;
var x, y: integer;
begin
writeln('введите два числа: x и y');
readln(x, y);
while (x>=1) and (y>=1) do
begin
x:=x div y;
y:=y-2;
end;
writeln (x);
writeln (y);
end.

Задания:

1. Набирите эту программу с программы Pascal ABC и узучите ответы.

2. Рассмотрите блок-схему 2 и напишите программу используя Pascal ABC.

3. Что будет выдавать программа, если при вводе х=6, y=8.

4. Что будет выдавать программа, если при вводе х=,1 y=0.

ответы записывайте через пробел.

valeraitrva valeraitrva    3   10.04.2020 14:29    1

Другие вопросы по теме Информатика