Поскорее можно? напишите программу,которая находит среднее из трех введенных числе. предполагается что все три числа различные

Vikak005love Vikak005love    1   24.06.2019 04:30    2

Ответы
ольга1724 ольга1724  19.07.2020 19:53
Я думаю, что имеется в виду среднее по значению
Pascal : 
var arr : array[0..2] of integer; { если числа целые }
     i, j, t : integer;
begin
  read(arr[0], arr[1], arr[2]); 
  // самый простой это отсортировать массив
  // в данном случае можно использовать сортировку "пузырьком"
  for i := 0 to 2 do 
    for j := 0 to 2 do 
      if arr[ j ] > arr[ j + 1]
        begin
          t := arr[ j ];
          arr[ j ] := arr[ j + 1];
          arr[ j + 1 ] := t;
        end;
 //Конечно, среднее по значению число будет храниться в элементе arr[1]
  writeln(arr[1]);
end.
На случай, если в учебнике просят среднее арифметическое, понятно, что нужно просто вывести ( arr[0] + arr[1] + arr[2] ) / 3
Если есть какие-то вопросы, то можете написать личное сообщение
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика