tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Пользователь вводит целое число
Пользователь вводит целое число а. программа должна определить, что куб суммы цифр этого числа равен а*а
номе498
3 18.08.2019 20:40
14
Ответы
57775858775847575
05.10.2020 03:27
#include <math.h>
#include <iostream>
using namespace std;
int main() {
int a,b;
cin >> a;
b = a;
int sum = 0;
while(abs(b) > 0) {
sum+=b%10;
b/=10;
}
if((sum*sum*sum) == (a*a)) cout << "yes" << endl;
else cout << "no" << endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
nastyagrng
29.03.2022 16:28
Скласти програму (в зошиті) до задачі: Обчислити середнє значення масиву, елементами якого є перші 9 членів арифметичної прогресії, перший член якої дорівнює 4, а знаменник-...
Weirdy
29.03.2022 16:45
Изображение обладающий большей реалистичностию...
vorler
29.03.2022 17:07
Я. Козловский. Стихотворение «Словарь — государь» Прочитайте стихотворение Яна Козловского. Есть волшебная страна, Что распахнута пред вами, Та, которая словами, Как людьми...
Mmamagadzhieva
29.03.2022 19:23
1. За якою схемою «приймають рішення» комп ютери? а) істинно/хибно; б) ймовірно/неймовірно; в) комп ютери не приймають рішень, оскільки їхні дії запрограмовані. 2. У чому...
mur181
29.03.2022 20:05
2. Составьте программу для определения, является ли х решением неравенства с модулем: x=int(input( Введите число: )) if (3*x-9 12): print(x является решением неравенства)...
21ololoha
29.03.2022 21:03
ЗАДАЧА С++ Визначити кількість цифр у даній послідовності....
MAXXB
29.03.2022 23:52
Почему калькулятор запрашивает геолокацию?...
C137
30.03.2022 00:57
Дано рівносторонній трикутник зі стороною a і коло радіусом r. Розробіть алгоритм і програму визначення: чи можна у трикутник вписати це коло. значення сторони трикутника...
gfyfhh
30.03.2022 02:01
1)Рассматривается множество целых чисел, принадлежащих числовому отрезку [3394; 8599], которые удовлетворяют следующим условиям: − остаток от деления на 3 равен 1;− остаток...
DenisYTYT
30.03.2022 03:00
Знайти добуток додатних чисел, перше з яких дорівнює 20, кожне наступне на 5 менше від попереднього. B scratch...
Популярные вопросы
Решите систему уровнения любым подстановки, {6(x-2)-4(x+3y)=4y-20 {2(y+4)-x=2x-2...
3
Перевести today, russia is not attractive to many tourists for a variety...
3
1. луч се делит прямой угол dсм на два угла dсе и есм. найдите градусную...
3
Решите подстановки система расстояние между двумя домами 900м из этих домов...
2
Спільнокореневі слова є в рядку а безтрашний, стражник, справжній б випадок,...
2
Вравнобедренном треугольнике abc. углы а и в равны 56 градусов.какая из...
1
Выражения 2(а+b)+3(а+b)+2а 2(2r-3s)-3(r-2s)...
3
Слова с парными звонкими и согласными в корне....
3
Написать сообщение на тему на построение в окружающем мире . заранее !...
2
C+o₂=co₂+394 кдж. определите сколько необходимо сжечь угля для получения...
1
#include <iostream>
using namespace std;
int main() {
int a,b;
cin >> a;
b = a;
int sum = 0;
while(abs(b) > 0) {
sum+=b%10;
b/=10;
}
if((sum*sum*sum) == (a*a)) cout << "yes" << endl;
else cout << "no" << endl;
}