получив на вход число x, ниже программа выводит два числа- m и n. var x, m, n: integer;

begin

readln (x);

m: =0; n: =0;

while x> 0 do

begin

if nm: =m+1;

x: =x div 10;

end;

writeln (m); writeln (n)

end.

известно, что при некотором значении х были выведены числа 4 и 8. укажите наибольшее и наименьшее из таких чисел х. сколько всего существует таких х?

даша3634 даша3634    1   22.01.2020 18:16    935

Ответы
tbbkc tbbkc  27.10.2021 15:02
Объяснение:

1)Число точно больше 100, чтобы L было 3.

2)Какие бы числа мы не ставили на позициях единиц и десятков, результата они никакого не дадут, тк отрезаются командой div

3)Ближайшее необходимое число: 500

Дописал программу, чтобы проверить. Она выводит количество подходящих комбинаций при вводе всех чисел от 1 до 500.

var

x, L, M,count,i: integer;

begin

count:=0;

for i:=1 to 500 do

begin

x:=i; L := 0;M := 0;

while x > 0 do

begin

L := L + 1; x := x div 10;

if L mod 2 = 0 then

M := M + (x mod 10);

end;

//write(L,' ');write(M);

if (L=3) and (M=5) then inc(count);

end;

writeln(count);

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика