По составить программу с дан целочисленный массив с числом элементов n и вывести из него нечетные элементы и их сумму. в паскале а если еще можно то блок схему)

ziksharof ziksharof    1   20.08.2019 08:10    2

Ответы
букет223 букет223  26.08.2020 07:25
Program mas;
const n=4; // число элементов
var a: array [1..n] of integer; //массив
i, sum: integer; //переменные
begin //начало
sum:=0; // сумма=0
for i:=1 to n do readln(a[i]); //вводим массив
for i:=1 to n do //цикл
if(a[i] mod 2 <>0) then //условие нечетности
begin
writeln(a[i]); //выводим нечетные
sum:=sum+a[i]; //считаем сумму
end;
writeln(sum); //выводим сумму
end. //конец
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика