По программированию на с++ с использованием оператора while () написать программу, которая будет выводить на экран: «введи многозначное число», затем считывать введенное с клавиатуры целое число, считать количество цифр и выводить на экран корректную фразу: «в числе ! число! ! результат! цифра/цифры/цифр»

JackDead JackDead    1   26.05.2019 12:28    14

Ответы
pomogiiiimne pomogiiiimne  01.10.2020 12:06

Объяснение:

#include "pch.h"

#include <stdio.h>

#include <iostream>

#include <cmath>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int num, k=0;

string str;

cout << "Введи многозначное число" << endl;

cin >> num;

while (num != 0)

{

 k += 1;

 num /= 10;

}

if(k==1)

{

 cout << k << " цифра" << endl;

}

else if (k >= 2 && k <= 4) {

 cout << k << " цифры" << endl;

}

else {

 cout << k << " цифр" << endl;

}

system("pause");

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы