По pascal abc. 90 ! используйте if, for, writeln, write, read, readln, var, begin, end, int64 и добавьте несколько переменных например: i,max. нужно на завтра к дана последовательность из 20 целых чисел. определите количество чисел в наиболее длинной подпоследовательности из подряд идущих нулей. формат входных данных в программу вводятся 20 целых чисел, принадлежащих диапазону [−215; 215−1], по 10 чисел на строке. формат выходных данных программа должна вывести количество нулей в наиболее длинной подпоследовательности. примеры входные данные 1 1 1 1 0 0 0 0 0 0 1 1 1 1 0 1 0 1 0 1 выходные данные 6
const n=20;
var a:array[1..n] of int64;
max, k, i, j: integer;
begin
for j:=0 to 1 do
begin
for i:=1 to n div 2 do read(a[j*10+i]);
readln;
end;
max:=0;
k:=0;
for i:=1 to n do
if a[i]=0 then k:=k+1
else begin
if k>max then max:=k;
k:=0;
end;
if k>max then max:=k;
writeln(max);
end.
Пример:
1 1 1 1 0 0 0 0 0 0
1 1 1 1 0 1 0 1 0 1
6