tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
По информатике в паскале.
По информатике в паскале. : составить программу вычисления суммы цифр числа, если кол-во неизвестно.
Coul2000nator
3 04.09.2019 12:30
1
Ответы
ketisvit2004
06.10.2020 16:52
Uses crt;
var a,b: Integer;
Begin
Write('Введите целое число: ');
Read a;
While a>0 do
Begin
b:=b+a mod 10;
a:=a div 10;
End;
Writeln('Сумма цифр введённого числа равна ', b);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kislova04
03.03.2019 01:50
Из слова видеоадаптер составляет слова: диод,радио,партер...
кактус107
03.03.2019 01:50
Нужно 4 предложения на тему наши школьные дела без ! кто даст ответ тому лучший !...
asiemghulkarimozb3er
07.08.2019 03:10
Мощность алфавита равна 64.сколько кбайт памяти потребуется,чтобы сохранить 128 страниц текста, содержащего в среднем 256 символов на каждой странице? можно с дано решение...
Айдан1231
30.11.2020 17:42
Построить таблицу истинности для выражения А&(AVBVC)=A*(A+B+C)...
Мухосранск462
30.11.2020 17:42
Ввод стандартный ввод или input.txt Вывод стандартный вывод или output.txtГермиона очень любит правильные четырехзначные числа. Как только она в транспорте приобретает билет...
KILLER435
30.11.2020 17:53
напишите наибольшее целое число x для которого истинно высказывание не(первая цифра четная) и не(последняя цифра нечетная) *решить задачей*...
ruslan426
30.11.2020 17:53
решить Решите следующее логическое выражение: В & (A v B v С), если А = 0, В = 1, С= 0 2. Постройте таблицу истинности для следующего логического выражения со всеми возможными...
olechka162
20.10.2020 03:46
тапсырма«Монитор» сөзінде қанша символ, қанша байт, қанша бит бар екенін анықта...
sofiko365
20.10.2020 03:45
Составьте программы (Python). 1. Ввести трехзначное число и вывести сколько в нем сотен, десятков, единиц. 2. Ввести номер места в купленном вагоне и вывести номер купе...
nitkind
20.10.2020 03:45
Lond АB1Модель равномерного движения2 ДанныеЗначения в системе си3 Путь, пройденный путником50004 Потраченное время36005 Скорость путника?- В2/C2=B3:34=B3%C4B3/B4...
Популярные вопросы
Составить рассказ о зимней одежде на казахском языке, 10-12 предложений....
2
Как проверить слово оказалась? первую букву о...
3
Опишите куклу: петрушку,ваньку встаньку,буратино и др. расскажите из чего...
1
Род число и падеж слов утренний клёв, неуловимые поплавки, зелёных кувшинок,...
3
Рожки какое проверечное слово чтоб проверить ж?...
3
Дайте полный развернутый ответ на вопрос: какой вред здоровью человека...
2
Кусок лентыдлиной 6м разрезали на мелкие кусочки.длина одной части0.5м...
3
Замени настоящее время глагола будущим сложным: молоко кипит,сирень цветет,мышь...
3
Продали в 1-й день - 7 ящиков печенья.во второй день - 13 ящиков печенья.вместимость...
2
Делать . поставьте следующие предложения в отрицательную и вопросительную...
2
var a,b: Integer;
Begin
Write('Введите целое число: ');
Read a;
While a>0 do
Begin
b:=b+a mod 10;
a:=a div 10;
End;
Writeln('Сумма цифр введённого числа равна ', b);
End.