По инфе! написать программу через pascalabc : з 2. составить программу, решающую следующую : дано трехзначное число. вывести число, полученное при перестановке крайних цифр исходного числа. 3. составить программу, решающую следующую : вы продавец, и у вас имеются гири весом 1, 2, 5 кг. наберите минимальное количество гирь для взвешивания n кг.

mariyaarif mariyaarif    1   26.08.2019 16:20    3

Ответы
Максим56065 Максим56065  05.10.2020 21:14
2.
var a,b:integer;
begin
write('a = ');
readln(a);
b:=(a mod 10)*100 + (a div 10 mod 10)*10 + a div 100;
writeln('b = ',b);
end.

Пример:
a = 194
b = 491

3.
var n,k5,k2,k1:integer;
begin
write('n = ');
readln(n);
k5:=n div 5;
k2:=(n-k5*5) div 2;
k1:=n-k5*5-k2*2;
writeln('5 кг - ',k5,', 2 кг - ',k2,', 1 кг - ',k1);
end.

Пример:
n = 18
5 кг - 3, 2 кг - 1, 1 кг - 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика