Плз! на языке паскаля составьте программу, которая по введенному вами k – числу грибов, печатает фразу «мы нашли в лесу k грибов, причем согласовывает окончание слова «гриб» с числом k.

Miliafert Miliafert    1   26.08.2019 10:30    4

Ответы
ishoeva ishoeva  05.10.2020 20:47
Var
k:integer;
Begin
Write('k = ');ReadLn(k);
Write('Мы нашли ',k);
if (k>9)and(k<20) then WriteLn(' грибов')
else
   Case k mod 10 of
   0,5..9:WriteLn(' грибов');
   1:WriteLn(' гриб');
   2..4:WriteLn(' гриба');
   End;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика