(Питон) Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(n) = n*n + 2*n + 1, при n > 25
F(n) = 2*F(n+1) + F(n+3), при чётных n ≤ 25
F(n) = F(n+2) + 3*F(n+5), при нечётных n ≤ 25
Определите количество натуральных значений n из отрезка [1; 1000], для которых значение F(n) не содержит цифру 0.

Я написала программу в чем ошибка?


(Питон) Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотн

MaxineCaulfield2003 MaxineCaulfield2003    1   14.06.2021 07:48    24

Ответы
Sasha13353747 Sasha13353747  14.07.2021 08:45

def F(n):

   if n>25:

       return n*n+2*n+1

   elif n<=25 and n%2==0:

       return 2*F(n+1) + F(n+3)

   elif n<=25 and n%2==1:

       return F(n+2) + 3*F(n+5)

k=0

for n in range(1,1001):

   if "0" in str(F(n)):

       k+=1

print(k)

вы забыли перевести результат в строчный вид, целочисленный тип данных не итерируется

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика