tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль ввести массив в(n)
Паскаль ввести массив в(n) целых чисел (n> =10). найти сумму последних пяти элементов массива и заменить ею первый элемент массива, если он отрицателен. массив и сумму распечатать.
Damirzic
1 14.09.2019 21:10
5
Ответы
neondragooffi
07.10.2020 15:14
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var b:=ReadArrReal('Вводите:',ReadInteger('n='));
var s:=b.TakeLast(5).Sum;
if b[0]<0 then b[0]:=s;
b.Println; Writeln('Сумма=',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Anchoys777
20.05.2019 03:30
Какие формы собственности на землю существовали в странах востока...
Otto111
14.10.2019 11:55
No2. сравните: 1536 бит 2 кбайта. 4096 байт. 4 кбайт....
Tkaiem
14.10.2019 11:56
Коаи. уо.для записи текста использовался чи алфавит. каждая страница со спользовался 4-символьный ждая страница содержит 30 строк по 10 символов в строке. какой объем информации содржат...
Ravik2K
14.10.2019 12:04
1. какие пары объектов находятся в отношении объект - модель ? а) компьютер – данные; б) компьютер - его функциональная схема; в) компьютер – программа; г) компьютер – алгоритм.2....
Мастер008
14.10.2019 12:08
100 . вычеслиье приближенно площадь фигуры, ограниченной пораболой y=x^2 и прямой y=5+x/2, разбивая отрезок изменения x на 10 частей и суммирая площадь прямоугольник с основанием,...
ddawka
14.10.2019 12:11
По искать дополнительно виды антивирусов.рассказать о их ....
bellalove200
14.10.2019 12:15
Составьте алгоритм,определяющий попадает ли заданное число а на интервал (c,d)....
Kulakoff
14.04.2020 19:42
Определите значение переменной d после выполнения программы Заранее...
VikaS11111
14.04.2020 19:42
Здравствуйте! Решите тест,уже час бьюсь,не могу сделать(...
gabennns
14.04.2020 19:42
ОЧЕНЬ класс У Оли есть доступ к сети Интернет по высокоскоростному одностороннему радиоканалу, обеспечивающему скорость получения информации 220 бит в секунду. У Маши нет скоростного...
Популярные вопросы
Есть 2 станции между которыми 550 км . на встречу друг к другу выехали 2 поезда...
1
Чем отличается словосочетание от предложения? 15...
3
64×(18+2)-549+36×9= найди значения выражения в столбик...
3
Сообщение: значение биологии в природе и жизни человека !...
1
Стоял яркий солнечный день.мы с братом шли через поле .вдруг на дорогу упала тень....
1
Сообщение значение растительных организмов...
2
Назови героев сказки теремок кто чем занят предложение по...
3
Сачыненне на тему книга навучыла, падказала,...
1
Так, характер иноуэ в плохом виде. например 1.неряшливая,плакса,жрёт сопли и др....
2
Постройте в ре миноре: s64 ,д6 ,д65 ! 10...
2
// Внимание! Если программа не работает, обновите версию!
begin
var b:=ReadArrReal('Вводите:',ReadInteger('n='));
var s:=b.TakeLast(5).Sum;
if b[0]<0 then b[0]:=s;
b.Println; Writeln('Сумма=',s)
end.