tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль. вообще нужна
Паскаль. вообще нужна программа в которую например вводишь число 120 и она говорит это число трехзначное или например 90 это число двухзначное
sophiek777
2 16.09.2019 14:50
2
Ответы
Mary240106
07.10.2020 19:55
Program dshvedkov;
var
n,k:integer;
begin
Write('n='); Read(n);
k:=0;
n:=Abs(n); // От минуса, иначе эта строка не нужна
while n>0 do begin
k:=k+1;
n:=n div 10
end;
Writeln('Число ',k,'-значное')
end.
Пример
n=120
Число 3-значное
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lilav
20.01.2021 18:07
Укажи правильный ответ, в пустое место впиши (скопируй) правильный ответ из списка, данного ниже. Носитель информации — это . Список: запоминать, сохранять и в нужный...
angelina1504
20.01.2021 18:07
Чем отличается свойство Captain для формы и для кнопки...
777495
20.01.2021 18:02
Төменде берілген программа кодтарын жазудағы қателерді тап....
alenajad
20.01.2021 18:00
Напишите программу, которая выводит на экран фразу: Everybody loves kittens . Python...
Симская
20.01.2021 17:57
Ессе на тему «життя без кросбраузерності «...
katizhi
20.01.2021 17:52
ИСТОРИЯ РАЗВИТИЯ РОБОТОВ 1поколение: 2поколение: 3поколение:...
КулБои
20.01.2021 17:49
Какие объекты могут иметь определенную вами по графику скорость?...
artyomka12
20.01.2021 17:43
Сколько путей существует из города А в город И через город В...
alinatima32
20.01.2021 17:38
Як часто збирається експертна група з питань рухомого зображення MPEG...
freedomman87
20.01.2021 17:38
Төменде берілген программа кодтарын жазуда жіберілген қателерді тап ...
Популярные вопросы
На каком счету казаков были сыновья тараса? чем они это заслужили?...
1
Все свои 20 пунктов за это сложное . в классе никто не смог решить,...
2
Отметьте, какие из перечисленных ни¬же противоречий явились причинами...
3
Составь программу действий и вычисли 126+(403 - 76) -259...
3
Во фруктовом саду растут 65 яблонь.осенью с каждой яблони сняли 200кг...
2
Вычислите площадь равнобедренной трапеции, если её основание 10 и...
1
Шесть предложений с одиночными причастиями...
3
Втрёх сосудах налиты жидкости равной массы. в каком сосуде находится...
1
Масса юпитера 1,9*10(в 27 степени) кг, его средний радиус 7,13*10(в...
1
Косинус(альфа-бетта)отнять косинус альфа * косинус бетта...
1
var
n,k:integer;
begin
Write('n='); Read(n);
k:=0;
n:=Abs(n); // От минуса, иначе эта строка не нужна
while n>0 do begin
k:=k+1;
n:=n div 10
end;
Writeln('Число ',k,'-значное')
end.
Пример
n=120
Число 3-значное