Паскаль важно)напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 4. количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число – максимальное число, кратное 4. пример работы программы:

8AnnaMur8 8AnnaMur8    2   15.04.2019 10:35    5

Ответы
danbka2707 danbka2707  29.05.2020 12:44

Объяснение:

var A:array [0..30000] of longint;

n,i,max:integer;

begin

read (n);

for i:=1 to n do begin

 A[i]:=random (30000);

 write (A[i],' ');

 end;

max:=A[1];

for i:=1 to n do begin

 if (A[i]>max) and (A[i] mod 4=0) then

 max:=A[i];

 end;

writeln ('Максимальное число кратное 4= ', max);

end.

Если тебе нужно вводить числа с клавиатуры замени строчку

A[i]:=random (30000);  на read (A[i]);

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика