Паскаль. в двумерном массиве найти сумму элементов главной и побочной диагонали, элемент, находящийся в центре должен быть посчитан лишь один раз. нужно написать программу.

emiliskenderov emiliskenderov    1   30.05.2019 22:50    3

Ответы
XOBasya XOBasya  01.07.2020 07:54
Var    matrix: array[1..5,1..5] of integer;    i, j: integer; sg:=0; sp:=0;begin    writeln ('Введите 25 чисел: ');     for i := 1 to 5 do        for j := 1 to 5 do            read (matrix[i,j]);     for i := 1 to 5 do begin        for j := 1 to 5 do            write (matrix[i,j], ' ');        writeln    end;  for i:=1 to 5 do begin   for j:= 1 to 5 do   if j=i then sg:=sg+matrix[i,j]; end; for i:=5 downto 1 do    begin    for j:=1to 5 do    if (i+j)=6 then sp:=sp+matrix[i,j]    end;    sp:=sp-matrix[3,3];1 writeln(sg,' ',sp);readlnend.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика