Паскаль. составьте программу вычисления в массиве a(n) произведения четных элементов. массив сформировать с генератора случайных чисел.

Ididhhxj Ididhhxj    1   22.05.2019 09:30    3

Ответы
nastya84756 nastya84756  01.10.2020 06:34

const

n=15;

var

a:array [1..n] of integer;

i:integer;

p:longint;

begin

randomize;

p:=1;

for i:=1 to n do begin

a[i]:=random(9)+1;

write (a[i]:2);

if a[i] mod 2 = 0 then p:=p*a[i];

end;

writeln; 

writeln ('Proizvedenie: ',p);

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика