tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль составить программу
Паскаль составить программу отсортировать 4 столбец двумерного массива по возрастанию (8 на 8)
bogdanmaltsev
2 07.09.2019 16:00
2
Ответы
rrrrrrrrtttttttttyyy
03.08.2020 21:29
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(8,8,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SetCol(3,a.Col(3).OrderBy(x->x).ToArray);
Writeln('*** Полученный массив ***'); a.Println(4)
end.
Пример
*** Исходный массив ***
77 68 79 -85 30 -28 -11 85
-52 -62 -94 -30 -82 31 -16 -80
-97 -95 84 -62 -53 5 68 -23
53 7 38 10 -88 -66 98 85
-99 -31 -6 71 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 -95 73 -55 -7 -27
99 3 -39 -77 33 78 73 -85
*** Полученный массив ***
77 68 79 -95 30 -28 -11 85
-52 -62 -94 -85 -82 31 -16 -80
-97 -95 84 -77 -53 5 68 -23
53 7 38 -62 -88 -66 98 85
-99 -31 -6 -30 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 10 73 -55 -7 -27
99 3 -39 71 33 78 73 -85
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
лох250
06.07.2019 11:10
Рассмотрите школьный урок как систему . опишите все кибернетические компоненты этой системы. обратите внимание на множественность различных механизмов прямой и обратной связи....
тяпница13
28.09.2019 00:00
Какая самая гланая программа компьютера? !...
Помошь0
28.09.2019 00:00
Перевести из десятеричной системы в двоичную 91, 17, 53, и из двоичной в десятеричную 110101, 011011, 111110. с решением. всем за ....
iruna4
28.09.2019 00:01
Дано целое число. проверить: является ли данное число отрицательным двузначным числом кратным десяти. в pascalabc...
eva77772
28.09.2019 00:01
Унас имеется неограниченное кол-во монет достоинством 2, 7 и 10 он хочет заплатить в точности 48. какое минимальное кол-во монет ему понадобится?...
LTKaty
28.09.2019 00:01
Чем характеризуется национальные информационные ресурсы?...
анечкалис
06.08.2019 05:10
1вопрос-что такое файл? 2 вопрос -что можно узнать о файле по его имени? из каких частей состоит файл? 3 вопрос-найди верное высказывание. 1файл имеет только имя. 2имя файла может...
Юля5451
06.08.2019 05:10
Почему в пэинте нет команды группировки...
света8612
30.07.2019 12:00
Вычисление катета прямоугольного треугольника. (паскаль)...
KILLER435
20.09.2019 05:10
Составить ребус к словам спормсмен, помидор, шоколад?...
Популярные вопросы
Знайдить перший член та ризницю арифметичнои прогресии an якщо a3=-80 a8=-25...
1
Сколько тетрадей можно купить на 6 р., если каждая тетрадь стоит 30 коп? А. 20...
3
Определи границы причастного оборотаПеремещай линии в строкуОпределяемое слово...
1
Васюткино озеро5. Перескажите подробно, как Васютка провёл первую ночь в тайге,...
3
решить задачу. Знайдіть суму перших п’яти членів геометричної прогресії (сn),...
3
Нужна по математике 4класс...
3
Определи, какой из примеров иллюстрирует магнитное действие электрического тока....
2
Тематична контрольна робота з української літератури 8 клас М. Коцюбинський, О....
3
Отрезок ВК - биссектриса прямоугольного треугольника АВС (угол С=90). Точка К...
3
Папа купил 18 кг моркови, в 2 раза больше лука и в 5 раз больше кортофеля, чем...
1
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(8,8,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
a.SetCol(3,a.Col(3).OrderBy(x->x).ToArray);
Writeln('*** Полученный массив ***'); a.Println(4)
end.
Пример
*** Исходный массив ***
77 68 79 -85 30 -28 -11 85
-52 -62 -94 -30 -82 31 -16 -80
-97 -95 84 -62 -53 5 68 -23
53 7 38 10 -88 -66 98 85
-99 -31 -6 71 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 -95 73 -55 -7 -27
99 3 -39 -77 33 78 73 -85
*** Полученный массив ***
77 68 79 -95 30 -28 -11 85
-52 -62 -94 -85 -82 31 -16 -80
-97 -95 84 -77 -53 5 68 -23
53 7 38 -62 -88 -66 98 85
-99 -31 -6 -30 32 -2 84 -87
45 46 -35 -2 -97 -46 -76 -66
-18 -10 72 10 73 -55 -7 -27
99 3 -39 71 33 78 73 -85