Паскаль. с клавиатуры введены 6 целых чисел. составьте программу, которая найдет из них наибольшее из них. использовать процедуру поиска большего из двух (бид).

1234567890854 1234567890854    2   12.03.2019 19:39    8

Ответы
RealBohdan RealBohdan  25.05.2020 02:43

//PascalABC.NET 3.4.2

var x, max: integer;

procedure my_max(x1, x2: ^integer);

begin

 if (x2^ > x1^) then x1^ := x2^;

end;

begin

 loop 6 do

 begin

   x := readinteger();

   my_max(@max, @x);

 end;

 write(max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика