tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль. решить через while.
Паскаль. решить через while. найти все двузначные числа, которые делятся на n и содержат в себе цифру n
kotlarovaira9
3 03.07.2019 18:40
1
Ответы
egorkarevyakin
27.07.2020 17:18
Var
A,N,C:byte;
B:boolean;
Begin
B:=false;
Write('N = ');ReadLn(N);
A:=10;
While A<100 do
Begin
if A mod N = 0 then
Begin
C:=A;
While C<>0 do
Begin
if C mod 10 = N then B:=true;
C:=C div 10
End;
if B then Write(A,' ');
B:=false
End;
A:=A+1
End
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
khezh073
22.11.2020 10:09
Написать программу на С# выводит первый столбец с положительными элементами (массив может быть и прямоугольным ...
matveykatvey13
25.05.2019 00:40
Что общего и в чём различие понятий модель и компьютерная модель ?...
Penguinunicirn
21.04.2020 17:54
Изменение масштаба изображения объектов, расположенных на плоскости называют * линейной перспективой обратной перспективой воздушной перспективой панорамной перспективой...
oladushek2002oy6bqn
28.06.2019 15:10
Написать словесный алгаритм светафора...
расулкрасава05
24.10.2021 19:10
НАПИШИТЕ ПРОГРАММУ НА ПИТОНЕ Сдать решение задачи B. Восстанови числа Восстанови числа Эта задача с открытыми тестами. Ее решением является набор ответов, а не программа...
Theyom47
24.10.2021 19:09
С процедуры определить: определить площадь и периметр каждого из 3 прямоугольников, который задан своими координатами вершин. ПАСКАЛЬ...
BC122
24.10.2021 19:09
Для чого застосовують режим структури документа в текстовому редакторі Microsoft Office Word? * 1.Для організації документів малого обсягу 2.Для нумерації змісту,...
basik100grn
26.04.2020 21:15
В стихотворении И.А.Бунина Помню - долгий зимний вечер... говорится о...
WaterdropE
26.04.2020 21:15
Составьте задачу на дефицит семейного бюджета ( )...
MaryLoveB
26.04.2020 21:15
В каком климатическом поясе расположена Украина ? Является ли наш климат комфортным для жизни людей и ведения хозяйства ?...
Популярные вопросы
Чому дорівнює шлях L і модуль переміщення S матеріальної точки,...
3
Сравнительный анализ мультфильма и повести Н.В.Гоголя Ночь перед...
2
Одну из этих тем.. Підготувати повідомлення на вибір: Обертальний...
1
Какие новые проблемы нарушали в своем творчестве гуманисты за пределами...
1
896543208765*543823409 сколько будет...
3
якщо столяр виготовлятиме 4 стільці щодня, то він виконає завдання...
3
Длина ребра полого чугунного куба (см. рисунок) равна 12 см. Какова...
1
Если в геометрической прогрессии: b2-b1 = 18, b3 – b1 = -18, то:...
2
И ПРОСТО предполагаемый и обоснованы ваш вариант развития событий...
2
Чим відрізняються між собою амінокислоти ...
2
A,N,C:byte;
B:boolean;
Begin
B:=false;
Write('N = ');ReadLn(N);
A:=10;
While A<100 do
Begin
if A mod N = 0 then
Begin
C:=A;
While C<>0 do
Begin
if C mod 10 = N then B:=true;
C:=C div 10
End;
if B then Write(A,' ');
B:=false
End;
A:=A+1
End
End.