tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль procedure f(n:
Паскаль procedure f(n: integer); begin if n < = 5 then begin f(n + 2); writeln (n); f(n + 3) end end чему равна сумма всех чисел, напечатанных на экране при выполнении вызова f(l)? (и как)
kistinakravcenk
2 16.07.2019 22:20
4
Ответы
tyuliganova
03.10.2020 06:04
ответ: 13.
А получается он вот так:
procedure F(n:integer);
begin
Writeln('Вызов F(',n,')');
if n <= 5 then begin
F(n + 2);
writeln('Процедура вывела ',n);
F(n + 3)
end
end;
begin
f(1)
end.
Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
маша111221
03.10.2019 09:01
При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 11 символов и содержащий только символы из 12-символьного набора. в базе...
Laurahsnbrg
03.10.2019 08:58
Як установити драйвера на виндовс7? ...
gogoja
03.10.2019 10:10
Сколько килобайтов состовляет сообщение из 512 символов в 16 символьном алфавите?...
aneechkaa000
03.10.2019 08:54
Решить 4 лёгкие задчки022кж50308 клоуны бам, бим и бом вышли на арену в красной, синей и зелёной рубашках. их туфли были тех же 3-х цветов. туфли и рубашка бима были...
nut56
03.10.2019 10:10
1) какое устройство пк ( персонального компьютера) предназначено для вывода информации? а) процессор б) монитор в) клавиатура г) магнитофон. 2) расположите величины...
Gibiskus2
11.11.2019 13:05
Расшифровать текст информатика...
madike
11.11.2019 13:05
Установите соответствие между определением и названием...
Maksim3131
11.11.2019 13:06
Составить функцию для расчёта....
напарницавМоскве
21.04.2020 12:44
очень что,по вашему мнению,стимулировало развитие технологий обработки текстовой информации?как это связано с понятием «безбумажные технологии»?наступит ли такое...
vtkmlth
09.08.2019 18:50
Основной характеристикой шины является: а.)разрядность в.)тактовая частота с.)емкость d.)длина...
Популярные вопросы
У поемі «Одіссея» розповідається: А про те, як Одіссей брав участь...
2
Рассчитать сумму собственного капитала по данным бухгалтерии:...
3
Познакомьтесь с последней песней «Колыбельная ручья» (№ 20). Какое...
2
В калориметре находится V1 = 3.0 л воды при температуре t1= 10...
3
Решите тест, русский язык 8 класс....
1
У плоский повітряний конденсатор з відстанню між обкладками d1...
1
Виділено 4 основні астрологічні дати, які визначає висота сонця...
1
Опис клім. поясів (коротко) То, что скинула учительница на фото.Ниже...
2
Верны ли следующие утверждения? А. Позиции России в Северной Америке...
3
2.05 Complete the table with words in exercise 1. Then listen...
3
А получается он вот так:
procedure F(n:integer);
begin
Writeln('Вызов F(',n,')');
if n <= 5 then begin
F(n + 2);
writeln('Процедура вывела ',n);
F(n + 3)
end
end;
begin
f(1)
end.
Результат работы программы:
Вызов F(1)
Вызов F(3)
Вызов F(5)
Вызов F(7)
Процедура вывела 5
Вызов F(8)
Процедура вывела 3
Вызов F(6)
Процедура вывела 1
Вызов F(4)
Вызов F(6)
Процедура вывела 4
Вызов F(7)