Паскаль. нужно написать программу, которая высчитывает среднею температуру, максимальную и минимальную температуру за месяц. вот, пытался написать сам, не получается: program pogoda; uses crt; var x, n, t : integer; max, min, imax, imin : integer; const z=5; begin for x : = 0 to z do; x : =1; while (x < z+1)do begin {создаем массив} while (x > z) do writeln; write ('какая температура была в '); write ( x); write (' день? '); readln (t); inc (x); end; max: = t[x]; for x: =0 to z do if max begin max: =t; imax: =x end else if min> t then begin min: =t; imin: =x end; writeln; writeln('максимальное значение ',max); writeln('в какой день месяца было максимальное значение ',imax); writeln('минимальное значение ',min); writeln('в какой день месяца было минимальное значение ',imin); readkey; end.

nikonova1977 nikonova1977    1   18.06.2019 13:10    3

Ответы
nastya4030 nastya4030  15.07.2020 07:21
Другие вопросы по теме Информатика