tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль! .необходимо найти среднее
Паскаль! .необходимо найти среднее арифметическое всех целых чисел от a до b. формат входных данных: вводятся два целых числа a и b(-2в15
тобик55555555
1 03.08.2019 13:20
4
Ответы
doncov2001
03.10.2020 20:34
Var
a,b,i:integer;
s:real;
begin
write('введите a: '); readln(a);
write('введите b: '); readln(b);
s:=0;
for i:=a to b do s:=s+i;
s:=s/(b-a+1);
write('Среднее арифметическое: ');
writeln(s:10:6);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ХЕЕЕЛПАНИТЕ
23.09.2019 22:20
Напишите программу на питоне, которая находит сумму, произведение, среднее арифметическое 3 произвольных чисел...
tasyasoloveva24
23.09.2019 22:20
Запиши выражение (4+z)2 на языке паскаль. (при записи ответа используй прописные буквы)....
TheHonorGaming
23.09.2019 22:20
Program pv4; var k, z, y, x: integer; begin writeln( введите целые числа- x, y ); readln(x,y); if x y then z: =x*y writeln(z) else k: =x+y writeln(k) end. пишет, что...
Валерия999111
27.04.2020 20:16
Запишите оператор который во время работы программы обеспечит вывод значений двух переменых one и two . и 2 целочисленым переменых z x y нужно присвоить соотвествено...
looney2017
23.12.2020 14:50
які виконують арифметичні операції в середовищі thonny чим вони відрізняються від математичних...
krudnya
23.12.2020 14:50
Опишите основные команды MS Word, позволяющие проверить правописание текста, и действия, которые нужно сделать для проверки....
89370982401
08.12.2020 23:56
5. ответить на вопросы по данному рисунку1. a. Какие инструменты использованы для создания многогранного объекта?b. В какой сфере (области) показан создаваемый объект...
nikita228928
08.12.2020 23:57
вопрос на который надо ответить я обвела...
makssanchuk
08.12.2020 23:57
Вариант 1. 1. Var тemp: array [3..18] of integer; Имя массива Сколько элементов в массиве? Тип данных в массиве 2. Числовой одномерный массив А заполнен последовательно...
IbraevaLisa
08.12.2020 23:58
Что такое команда по созданию эффектов векторного изображениа?...
Популярные вопросы
Катет прямокутного трикутника дорівнює ( а) , а прилеглий гострий...
1
1)(x-3)(3x^2-4x-20)/7x^2-27x-40≥02)1/x-3≥x-2...
1
Use the present perfect continuos or the present perfect to complete...
3
Решите выделенное Пример запишите тоже...
3
Отметье на карте направление первой волны миграции гуннов на территории...
2
Не решая уравнение x2+4x+7x+28=0 , определи, имеет ли оно корни....
1
Дано линейное уравнение с двумя переменными5x−9y+30=0.Используя его,...
2
1. 1) Тік бұрыш қанша градустан тұрады? 2) Кез келген сүйір бұрыш-ты...
2
Постройте графики линейных уравнений х-у=3; 3х+у=1; 6х-3у=9...
2
Письменно ответить на во Почему в природе нет чистой воды? 2) Какие...
1
a,b,i:integer;
s:real;
begin
write('введите a: '); readln(a);
write('введите b: '); readln(b);
s:=0;
for i:=a to b do s:=s+i;
s:=s/(b-a+1);
write('Среднее арифметическое: ');
writeln(s:10:6);
end.