Паскаль. напишите программу, которая запрашивает ввод массива b и выводит на экран его элементы в табличной форме: 1 2 3 4 2 3 4 5 3 4 5 6 выведите на экран среднее арифметическое элементов массива b.

voprooos voprooos    1   22.09.2019 15:01    5

Ответы
tanzbis tanzbis  08.10.2020 09:52
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  var b:=ReadMatrInteger(m,n);
  b.Println(4); Writeln(4*b.ColCount*'-');
  Writeln('Ср.арифм. равно ',b.ElementsByRow.Average)
end.

Пример
Количество строк и столбцов в массиве: 3 4
1 2 3 4
2 3 4 5
3 4 5 6
   1   2   3   4
   2   3   4   5
   3   4   5   6

Ср.арифм. равно 3.5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика