Паскаль напишите программу, которая выводит на экран массив в в одну строку и определяет количество четных и количество нечетных элементов.

Qqertyi Qqertyi    2   22.09.2019 15:01    2

Ответы
sanek15604 sanek15604  08.10.2020 09:52
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var b:=ArrRandom(ReadInteger('n='),-50,50); b.Println;
  Writeln('Четных элементов ',
      b.Where(t->t.IsEven).Count,
      ', нечетных ',
      b.Where(t->t.IsOdd).Count)
end.

Пример
n= 20
-18 -1 48 -31 -18 -34 -42 20 -30 14 -16 45 50 0 -18 39 45 19 -10 16
Четных элементов 14, нечетных 6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика