Паскаль! Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число - сумму чисел, кратных 3.

nastya30071 nastya30071    3   01.11.2020 23:56    2

Ответы
LoliTyan1 LoliTyan1  01.12.2020 23:57

program amountnumbers3;

var

 quantity, amount, number, counter: integer;

begin

 counter := 0;

 amount := 0;

 write('Введите количество чисел: ');

 read(quantity);

 while counter <> quantity do

 begin

   read(number);

   if (number mod 3 = 0) then

     inc(amount, number);

   inc(counter);

 end;

 write('Сумма чисел, кратных 3 = ', amount);

end.

Объяснение:

program amountnumbers3;  // Название программы

var

 quantity, amount, number, counter: integer;  // Создание целочисленных переменных:

quantity - количество чисел в последовательностиamount - сумма чисел, кратных 3number - числа - переменная счетчик

begin  // Начало программы

 counter := 0;  // Переменная счетчик = 0

 amount := 0;  // Переменная, хранящая сумму = 0

 write('Введите количество чисел: ');  // Вывод сообщения в консоль

 read(quantity);  // Считывание количества чисел в последовательности с клавиатуры

 while counter <> quantity do  // Пока значение переменной counter ≠ значению переменной quantity, выполняй

 begin  // Начало цикла

   read(number);  // Считываем число последовательности с клавиатуры

   if (number mod 3 = 0) then  // Если остаток от деления при делении значения переменной number на 3 = 0, тогда

     inc(amount, number);  // Увеличиваем значение переменной amount на number

   inc(counter);  // Увеличиваем значение переменной counter на единицу

 end;  // Конец цикла

 write('Сумма чисел, кратных 3 = ', amount);  // Вывод ответа

end. // Конец программы

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика