tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль. напишите программу,
Паскаль. напишите программу, которая по последней цифре числа определяет последнюю цифру квадрата этого числа
kirill885
1 15.08.2019 05:10
2
Ответы
настюха20998
08.09.2020 14:56
Var a, b: longint;
begin
write ('введите число -> ');
readln (a);
a:=a mod 10;
b:=(a*a) mod 10;
writeln ('последняя цифра квадрата числа -> ',b);
end.
ПОКАЗАТЬ ОТВЕТЫ
foxheb57
08.09.2020 14:56
Var i: Integer;
begin
write('Число: ');
readLn(i);
i := i mod 10;
writeLn('Цифра квадрата = ',
sqr(i) mod 10);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dgony2003
27.01.2021 20:13
Вводится последовательность целых чисел (2 или больше числа) , меньших `1000` по модулю, `1001` конец последовательности. Определить максимальную сумму коэффициентов уравнения...
lauraumirzhan55
27.01.2021 20:11
Напишите программу на Паскале для решения следующей задачи. Даны два числа A и B, которые не равны друг другу. Большее из этих чисел нужно заменить половиной разности этих...
Denis1930
27.01.2021 20:11
Написать программу суммирования отрицательных четных чисел, оканчивающихся на 4 в последовательности 10 целых чисел...
vadimbukov
27.01.2021 20:10
Алуа құралдарды таңдап, тінтуірдің он жақ батырмасымен сурет сала бастады. Алуа не салады? DOGA ◇O0ゆПішіндерЖасыл үшбұрышЖасыл сопақҚызғылт сопақҚызғылт тіктөртбұрышЖоспарТолтыру...
ChocoPie12
27.01.2021 20:08
Что общего и в чем отличие Компьютерных Вирусов и Компьютерного Пиратства...
vika20022003
27.01.2021 20:04
Вводится последовательность натуральных чисел. Вывести максимальное простое число из последовательности....
Дженнет2001
27.01.2021 20:04
2.Система предписаний для решения конкретной задачи а.процедурные программы б.приказы в.низкие программы г компиляторы...
Valerykh123
27.01.2021 20:03
как можно убедиться что формула ссылается на нужные ячейки?после ввода в ячейку таблицы формулы 2*А1+6 Вася увидел,что табличный процессор не вычислил нужное значение.В чем...
savolyukm
27.01.2021 20:03
Позиционные системы счисления) Непозиционные системы счисления...
shijoatova48
27.01.2021 20:02
Напишите программу, которая найдет сумму ТРЕХ чисел....
Популярные вопросы
Место в обществе Занятие Малый князь Простой народ БЫСТРЕЕ...
3
Основні центри виробництва меблів...
2
Функция задана уравнениемy=-x^2-4x+12...(все на фото) ...
2
Дано арифметичну прогресію: 4,2; 3,4; 2,6; ... Починаючи з якого номера...
1
Запиши в виде десятичной дроби:...
1
Каким было географическое положение Галицко-Волынского княжества? Опишите...
3
Образ лікаря у романі М.Булгакова «Записки юного лікаря».Твір за схемою...
2
Образовать от данных прилагательных наречия. Мужественный – Дружественный...
1
[5] Оқылым2-тапсырма. Мәтінді оқы. Мәтін бойынша тапсырмаларды орында.Ұшақ...
3
Дана арифметическая прогрессия 7; 12; 17; ... . Какое число стоит в этой...
1
begin
write ('введите число -> ');
readln (a);
a:=a mod 10;
b:=(a*a) mod 10;
writeln ('последняя цифра квадрата числа -> ',b);
end.
begin
write('Число: ');
readLn(i);
i := i mod 10;
writeLn('Цифра квадрата = ',
sqr(i) mod 10);
end.