Паскаль! напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Мусора12233334555 Мусора12233334555    2   08.08.2019 03:50    3

Ответы
Викусик1258 Викусик1258  04.10.2020 04:19
Var
  n,i:integer;
  s:string;
begin
  Write('Введите натуральное число: '); Read(n);
  Str(n,s);
  for i:=2 to Length(s) do
    if s[i]=s[i-1] then begin
      Writeln('Пара одинаковых цифр-соседей ',s[i]);
      Exit
      end;
  Writeln('В числе нет цифр, имеющих таких же соседей')
end.

Пример
Введите натуральное число: 375422453
Пара одинаковых цифр-соседей 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика