Паскаль напишите программу, которая 10 раз запрашивает ввод целого числа. при завершении ввода на экран выводится сумма чисел, минимальное число, максимальное число.

SHILW SHILW    3   05.06.2019 18:50    5

Ответы
Lsjsjajj Lsjsjajj  01.10.2020 20:07
Program Lana132;
uses crt;
const n=10;
var
  i,ch,max,min,sum:integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа запрашивает N чисел, находит их сумму, максимальное и минимальное число');
  sum:=0;
  write('Введите 1-e число: '); read(ch);
  sum:=sum+ch;
  max:=ch; min:=ch;
  for i:=2 to n do
    begin
      write('Введите ',i,'-e число: '); read(ch);
      sum:=sum+ch;
      if max<ch then max:=ch;
      if min>ch then min:=ch;
   end;
  writeln('Сумма всех чисел равна ',sum);
  writeln('Максимальное число равно ',max);
  writeln('Минимальное число равно ',min);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика