Паскаль Написать программу, которая вычисляет Стоимость оплаты за электроэнергию за
текущий месяц. Известно, что СТОИМОСТЬ начисляется по схеме:
До 100 кВт - 90 коп. за кВт;
От 100 кВт до 500 кВт - 168 коп. за кВт;
Более 500 кВт - 224 коп. за кВт;
Количество кВт использованной ЭНЕРГИИ вводиться с клавиатуры.
Выполнить защиту от неправильного ввода данных
Записать конечной результат в файл
begin
var N,B:real;
write('Введите количество кВт: '); readln(N);
if N<0 then write('Некорректный ввод: значение должно быть положительным') else
begin
case N.Round of
0..99:B:=N*0.96;
100..500:B:=N*1.68;
else B:=N*2.24;
end;
append(output,'output.txt');
write(output,'Использовано энергии '+N+' кВт на сумму '+B+' рублей');
end;
end.
Примечание:
Программа может выдать ошибку при попытке подключения к файлу output.txt в коренной папке Паскаля. В таком случае нужно создать другой файл, и поместить его в ту же папку, после чего заменить имя 'output.txt' на имя нового файла в процедурах append и write.