Паскаль написать программу которая по введенному четырехзначному числу выводит сумму его цифр.

helpplizzzz helpplizzzz    2   31.08.2019 11:20    0

Ответы
ShkolnikN15 ShkolnikN15  06.10.2020 07:08
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var t:=Abs(ReadInteger('n='));
  var s:=0;
  while t>0 do begin
    s:=s+t mod 10;
    t:=t div 10
    end;
  Writeln('Сумма цифр равна ',s)
end.

Пример
n= 3048
Сумма цифр равна 15

Замечание: число не обязательно должно быть четырехзначным и не обязательно положительным.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика