Паскаль. написать программу для трехзначного числа и вычислить на сколько старший разряд больше младшего.

ChrisUnte ChrisUnte    3   19.09.2019 08:30    4

Ответы
Эхэхэхэххэ Эхэхэхэххэ  08.10.2020 01:55
Var   i, n:integer; b:array[1..3] of integer;begin    write('Type integer: ');    readln(n);    if n<0 then        n:=-n; // уничтожение знака числа     repeat    i:= i + 1;        b[i] := (n mod 10); // вывод последней цифры числа        n:= n div 10; // удаление последней цифры числа    until n=0;    if b[3] > b[2] thenwriteln('Цифра сотен больше десятков ',b[3] - b[2])elsewriteln('Цифра сотен меньше десятков ',b[2] - b[3]);if b[2] > b[1] thenwriteln('Цифра десятков больше единиц ',b[2] - b[1])elsewriteln('Цифра десятков меньше единиц ',b[1] - b[2]);end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика