Паскаль написать программу для нахождения суммы большего и меньшего из трех чисел. указание: для решения использовать подпрограммы вычисления минимального и максимального для двух чисел. пример на входе: 45 72 24 на выходе: 96

lenaglukhova20 lenaglukhova20    1   24.09.2019 05:50    1

Ответы
TheATN TheATN  08.10.2020 14:13
Var
  a, b, c: integer;

function min_3(const a, b, c: integer): integer;
var
  local_min: integer;
begin
  if (a < b) then
    local_min := a
  else
    local_min := b;
      if (c < local_min) then
    local_min := c;
      Result := local_min
end;

function max_3(const a, b, c: integer): integer;
var
  local_max: integer;
begin
  if (a >= b) then
      local_max := a
  else
      local_max := b;
       
  if (c > local_max) then
      local_max := c;

  Result := local_max;
end;

begin
  writeln('Введите a, b, c -> ');
  readln(a, b, c);
  writeln('Результат: ', min_3(a, b, c) + max_3(a, b, c), '.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика