Паскаль! Надо написать программу используя while-do,программа должна иметь практическое применение в жизни.

miha115 miha115    1   02.03.2021 11:57    3

Ответы
Alishkek Alishkek  01.04.2021 11:59

#include <iostream>

using namespace std;

int main ()

{

   setlocale(0, "");

   int i = 0; // инициализируем счетчик цикла.

   int sum = 0; // инициализируем счетчик суммы.

   do {// выполняем цикл.

       i++;

       sum += i;

   } while (i < 1000); // пока выполняется условие.

   cout << "Сумма чисел от 1 до 1000 = " << sum << endl;

   return 0;

}

Объяснение:

Цикл do while

Цикл do while очень похож на цикл while. Единственное их различие в том, что при выполнении цикла do while один проход цикла будет выполнен независимо от условия. Решение задачи на поиск суммы чисел от 1 до 1000, с применением цикла do while.

Принципиального отличия нет, но если присвоить переменной i значение, большее, чем 1000, то цикл все равно выполнит хотя бы один проход.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика