tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Паскаль! на плоскости
Паскаль! на плоскости заданы три точки своими координатами. определить расстояние от точек до начала координат и напечатать, какая из точек расположена ближе к началу координат. (с повтором)
motay121
2 26.08.2019 10:30
4
Ответы
miliolia125
05.10.2020 20:47
Var x1,y1,x2,y2,x3,y3,r1,r2,r3:real; min,p:integer;
begin
repeat
write('x1, y1: ');
readln(x1,y1);
write('x2, y2: ');
readln(x2,y2);
write('x3, y3: ');
readln(x3,y3);
r1:=sqrt(x1*x1+y1*y1);
r2:=sqrt(x2*x2+y2*y2);
r3:=sqrt(x3*x3+y3*y3);
writeln('r1 = ',r1:5:2,' r2 = ',r2:5:2,' r3 = ',r3:5:2);
if r1<r2 then min:=1 else min:=2;
if r3<min then min:=3;
writeln('К началу координат ближе точка № ',min);
write('Хотите повторить? (1-да, 0-нет) ');
readln(p);
until p<>1;
end.
Пример:
x1, y1: 3 -2
x2, y2: -4 1
x3, y3: 5 0
r1 = 3.61 r2 = 4.12 r3 = 5.00
К началу координат ближе точка № 1
Хотите повторить? (1-да, 0-нет) 1
x1, y1: 8 0
x2, y2: -3 4
x3, y3: 5 -2
r1 = 8.00 r2 = 5.00 r3 = 5.39
К началу координат ближе точка № 2
Хотите повторить? (1-да, 0-нет) 0
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
OOAAAOO
26.05.2019 19:50
Вцелочисленной последовательности есть нулевые элементы. создать массив из номеров этих элементов. то-есть дан массив в которым есть нулевые значения.например: 20330120...
rhxtdf
26.05.2019 19:50
Напишите простейшую в pascal (алгоритмы ветвления if then): ввести возраст человека (от 1 до 150 лет) и вывести его вместе с последующим словом год , года , лет . например,...
lilitabraamyan
26.05.2019 19:50
Постфиксное выражение – это числовое выражение, в котором сначала записываются операнды, а затем знак операции. например: 3 5 + означает 3+5. особенностью постфиксных выражений...
alice108
26.05.2019 19:50
Задан ряд последовательных натуральных чисел от n до m (n...
OlesyaKotova1
17.12.2019 12:08
Напишите программу: подсчитать количество нулей в массиве, состоящем из n целых чисел. элементы массива задавать вручную. 9 класс, : )...
Бла161
17.12.2019 12:10
Поднять перосместиться в точку (3,1)опустить перосместиться на вектор(2,0)сместиться на вектор(1,4)сместиться на вектор(-4,0)сместиться на вектор(1,-1поднять перосместиться...
annar2001
17.12.2019 12:16
Реши . черно-белое (без градаций серого) графическое изображение имеет размер 34×34 точек. какой объём памяти займёт это изображение? ответ: бит....
nastya2747
17.12.2019 12:17
Алгоритм створення тривимірної графіки...
wellbiss
17.12.2019 12:18
Запиши число 12753 в развёрнутом виде, начиная со старшего разряда....
лера23451
17.12.2019 12:21
Синформатикой. с клавиатуры вводят массу тела и объема. написать программу, которая находит плотность теле. решить для исходных данных: а) масса - 2225 кг ; объём -0,25...
Популярные вопросы
Задали на завтра пересказать текст который ещё не читали. нам сказали...
1
Найдите координаты точки пересечения графиков функций у=-х+2 у=1.5х-2...
2
После строительство дома осталось некоторое количество плиток их можно...
1
Найдите 1)1 % от числа 76 4)30 % от числа 120 2)7 % от числа 300 5)94...
1
Найдите длину вектора (αβ) по данным координатам точек: α(1; -1),b(-2;...
3
Решите систему уравнений 3x^2+y=6 4x^2-y=1...
2
Найдите значение выражения 398,6 – 3,8∙7,7 + 3: 0,06 желательно по действием...
3
Периметр комнаты 28 м, ширина комнаты 6 м. найди площадь комнаты....
2
Через лампочку, которая подключена к напряжению 16,4 в, протекает ток...
3
Составь предложения со словами перевертышами . дед.а лес у села.шашлык...
2
begin
repeat
write('x1, y1: ');
readln(x1,y1);
write('x2, y2: ');
readln(x2,y2);
write('x3, y3: ');
readln(x3,y3);
r1:=sqrt(x1*x1+y1*y1);
r2:=sqrt(x2*x2+y2*y2);
r3:=sqrt(x3*x3+y3*y3);
writeln('r1 = ',r1:5:2,' r2 = ',r2:5:2,' r3 = ',r3:5:2);
if r1<r2 then min:=1 else min:=2;
if r3<min then min:=3;
writeln('К началу координат ближе точка № ',min);
write('Хотите повторить? (1-да, 0-нет) ');
readln(p);
until p<>1;
end.
Пример:
x1, y1: 3 -2
x2, y2: -4 1
x3, y3: 5 0
r1 = 3.61 r2 = 4.12 r3 = 5.00
К началу координат ближе точка № 1
Хотите повторить? (1-да, 0-нет) 1
x1, y1: 8 0
x2, y2: -3 4
x3, y3: 5 -2
r1 = 8.00 r2 = 5.00 r3 = 5.39
К началу координат ближе точка № 2
Хотите повторить? (1-да, 0-нет) 0