Паскаль, ? кто тут гений информатики? , ! написать программу и блок-схему дан массив из 10 целых чисел, заполненный генератором случайных чисел. найти минимальный элемент в массиве и подсчитать количество таких элементов в массиве.

mur181 mur181    1   21.07.2019 10:50    5

Ответы
Сергей12318 Сергей12318  23.09.2020 08:25
Program p12;
type tab=array[1..10] of integer;
var t:tab;
i,k,min:integer;
begin
min:=100;
for i:=1 to 10 do
t[i]:=random(10);
for i:=1 to 10 do
if(t[i]<min) then min:=t[i];
for i:=1 to 10 do
if(t[i]=min) then k:=k+1;
write('массив: ');
for i:=1 to 10 do
write(t[i],' ');
writeln;
writeln('Меньшее число ',min);
write('Количество меньших чисел ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика