Паскаль доделать вклад в банке составляет x рублей. ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. каждый год сумма вклада становится больше. определите, через сколько лет вклад составит не менее y рублей. входные данные программа получает на вход три натуральных числа: x, p, y. выходные данные программа должна вывести одно целое число. program u1; var x, p ,s,n: integer; y: real; begin read(x); read(p); read(y); s: =0; s: = x +(x*p)div 100; n: = 1; while (s < y) do begin s : = s +((s*p)div 100); n: = n + 1; end; writeln (n); readln; end. здесь где-то есть недоработка.

sanyakuzmin01 sanyakuzmin01    3   18.08.2019 05:50    16

Ответы
SviYm SviYm  05.10.2020 02:20
Program u1;
var 
x, p ,y, s, n: integer;
begin
readln(x,p,y); 
s:=x;
n:= 0; 
while (s < y) do 
begin 
s := s+trunc((s*p)/100); 
n:= n+1; 
end; 
writeln(n);
end.

Пример:
100 10 500
18
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика