Паскаль: дан текст. слова в тексте разделены одним или несколькими пробелами. написать программу, выводящую все слова, начинающиеся с гласных букв алфавита.

3296121116i 3296121116i    3   17.09.2019 16:00    4

Ответы
anchousuchixa anchousuchixa  07.10.2020 22:08
var
i:integer;
s:string;
const
glas=['Й','У','Е','Ы','А','О','Э','Я','И','Ю'];
beginwrite ('Vvedite predlohenie: ');
readln (s);
i:=1;
while i<=length (s) do     
begin           
if ((i=1) or (s[i-1]=' ')) and (s[i] in glas) then           
begin             
while not ((s[i] in ['.',',',';','!','?',':',' '])) and (i<=length (s)) do                   
begin                         
write (s[i]);                         
i:=i+1;                   
end;             
writeln;           
end;         
i:=i+1;     
end;
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика