Паскаль:через составной оператор Beginend составить программу, которая вычисляет сумму и среднее арифметическое положительных чисел

cet6990 cet6990    2   18.05.2020 17:48    3

Ответы
timkazhimov timkazhimov  14.10.2020 23:08

Program p1;

Var a, i, n, k,z: integer;

Begin

Write('Введите количество чисел: ');

readln(n);

k:=0;

z:=0;

For i:=1 to n do begin

readln (a);

if (a > 0) then k:=k + a;

z:=z + 1;

end;

Writeln('Сумма положительных чисел = ',k);

Writeln('Среднее арифметическое чисел = ',k/z);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика