tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
(паскаль авс): среди натуральных
(паскаль авс): среди натуральных трехзначных чисел найти те, сумма цифр которых равна заданному числу а, а само число при делении на 4 дает остаток 3.
Ruta12340
3 08.07.2019 11:40
9
Ответы
rfvbkz28
19.08.2020 06:50
Var a,b,i,s1,s2,s3:integer;
begin;
readln(a);
for i:=100 to 999 do
begin;
b:=i;
s1:=b mod 10;
b:=b div 10;
s2:=b mod 10;
b:=b div 10;
s3:=b mod 10;
b:=b div 10;
if (i mod 4=3) and (s1+s2+s3=a) then writeln(i);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
shastononelove2
04.06.2019 07:30
Дан текст из 600 символов. известно, что символы берутся из таблицы размером 16 х 32. опаределите информационный объем текста в битах...
sevasik12
04.06.2019 07:30
Вывести на экран в столбик результаты таблицы умножения на 2. в кумире...
alpysovat
04.06.2019 07:30
Всистеме счисления с некоторым основанием десятичное число 34, записывается в виде 42. какое это основание?...
Julia517517
04.05.2020 17:43
Які етапи створення сайта зазвичай передають його наповненню контентом...
nadya1801
04.05.2020 17:44
Які розгалуження називають вкладеними...
lukycuk
16.09.2021 05:37
Анар хочет поздравить бабушку с 80 летием но она живёт в другом городе для этого она сделала поздравительное видео, но не знает, как отправить его своей бабушке Анар, выбери...
AsassinGirl
27.05.2019 11:50
Назовите элементы файловой структуры...
света1094
25.03.2019 13:30
Имя входного файла: e.in имя выходного файла e.out дается.. имя входного файла: e.in имя выходного файла e.out дается последовательность из n чисел.найдите максимальное...
Гена102
25.03.2019 13:30
Вводится n целых чисел. верно ли что отрицательный чисел больше чем положительных?...
millizza11
25.03.2019 13:20
Передавались ли у египтян иероглифами гласные звуки?...
Популярные вопросы
Розставте коефіцієнти в схемах:K+O2=K2O;KClO3=KCl+O2;Li+H2O=LiOH+H2;Fe2O3+HCl=FeCl3+H2O;FeCl2+Cl2=FeCl3...
3
Нет ничего такого, что нельзя было бы уложить в ясные слова. Как часть...
2
Stunde 10 Образуй множественное число и переведи на русский язык...
2
Напишите уравнение окружности с центром в точке A (2;1), проходящей через...
3
Написать подробные определения трагедии, комедии, драмы как драматургических...
1
У прямокутному трикутнику abc(кут c дорівнює 90°) довжина катета ac дорівнює...
2
As soon as it (start) to rain, the (take) her umbrellaРозкрити дужки,...
2
Кто вел борьбу с Джунгар-ским нашествии-ем ...
2
Самостійна робота з української мови Переписати речення, поставити розділові...
2
7. «Книга про бойца» является подзаголовком: 8. Какой поэт написал стихотворение,...
1
begin;
readln(a);
for i:=100 to 999 do
begin;
b:=i;
s1:=b mod 10;
b:=b div 10;
s2:=b mod 10;
b:=b div 10;
s3:=b mod 10;
b:=b div 10;
if (i mod 4=3) and (s1+s2+s3=a) then writeln(i);
end;
end.